Reader Interface
Internet explorer version 10+
For Chrome, Firefox, Safari, Edge we support the current and previous version

Admin Interface
Internet explorer version 11+
For Chrome, Firefox, Safari, Edge we support the current and previous version

Did this answer your question?